CISCO 2950, very simple VLAN'ing

poohbeer

Junior Member
Mar 24, 2001
7
0
0
Got a Cisco 2950 and trying to use 802.1q to connect it's vlans with an extreme networks summit48. For now however just the basic setup on the cisco not connected to the summit48 with 2 vlans. See my problem and the config below.
I don't have any cisco experience so I might be doing something awfully stupid here but i cannot get it working.

Problem:

Switch(config)#int vlan 1000
Switch(config-if)#no shut
Switch(config-if)#
20:17:33: %LINK-3-UPDOWN: Interface Vlan1000, changed state to up
20:17:33: %LINK-5-CHANGED: Interface Vlan10, changed state to administratively down
20:17:34: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to down
Switch(config-if)#exit
Switch(config)#int vlan 10
Switch(config-if)#no shut
Switch(config-if)#
20:18:02: %LINK-3-UPDOWN: Interface Vlan10, changed state to up
20:18:03: %LINK-5-CHANGED: Interface Vlan1000, changed state to administratively down
20:18:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up



configuration:

Current configuration : 2259 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
ip subnet-zero
vtp mode transparent
!
vlan 10
name akzo
!
vlan 1000
name switches
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
switchport access vlan 10
no ip address
!
interface FastEthernet0/2
switchport access vlan 10
no ip address
!
interface FastEthernet0/3
switchport access vlan 10
no ip address
!
interface FastEthernet0/4
switchport access vlan 10
no ip address
!
interface FastEthernet0/5
switchport access vlan 10
no ip address
!
interface FastEthernet0/6
switchport access vlan 10
no ip address
!
interface FastEthernet0/7
switchport access vlan 10
no ip address
!
interface FastEthernet0/8
switchport access vlan 10
no ip address
!
interface FastEthernet0/9
switchport access vlan 10
no ip address
!
interface FastEthernet0/10
switchport access vlan 10
no ip address
!
interface FastEthernet0/11
switchport access vlan 10
no ip address
!
interface FastEthernet0/12
switchport access vlan 10
no ip address
!
interface FastEthernet0/13
switchport access vlan 10
no ip address
!
interface FastEthernet0/14
switchport access vlan 10
no ip address
!
interface FastEthernet0/15
switchport access vlan 10
no ip address
!
interface FastEthernet0/16
switchport access vlan 10
no ip address
!
interface FastEthernet0/17
switchport access vlan 10
no ip address
!
interface FastEthernet0/18
switchport access vlan 10
no ip address
!
interface FastEthernet0/19
switchport access vlan 10
no ip address
!
interface FastEthernet0/20
switchport access vlan 10
no ip address
!
interface FastEthernet0/21
switchport access vlan 10
no ip address
!
interface FastEthernet0/22
switchport access vlan 10
no ip address
!
interface FastEthernet0/23
switchport access vlan 1000
no ip address
!
interface FastEthernet0/24
no ip address
!
interface GigabitEthernet0/1
no ip address
!
interface GigabitEthernet0/2
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan10
no ip address
no ip route-cache
!
interface Vlan1000
no ip address
no ip route-cache
shutdown
!
ip http server
!
!
line con 0
line vty 5 15
!
end
 
Jun 6, 2005
34
0
0
I'm going to assume that the point of this is to have 2 active VLAN interfaces on the 2950? And when I say interfaces, I mean IP enabled interfaces (L3), not just a L2 VLAN.

Lets start with square 1: a 2950 is an access layer device and only supports (1) active L3, IP enable VLAN interface for management. The 2950 doesn't do routing, so the use of having 2 IP enabled VLANs would be pointless, they couldn't route between each other. You can only have 1 "ip default-gateway", which will route any management traffic back out the single active VLAN interface. Hope that all made sense..

So if your point is to create 2 VLAN interfaces (with IP's), like this:

conf t

interface vlan 1000
ip address 10.1.1.1 255.255.255.0
no shut


interface vlan 10
ip address 10.10.10.1 255.255.255.0
no shut

Then it won't work. You can't have 2 active IP's or VLAN intefaces on a 2950.

If having IP's enabled on the switches for these VLANs isn't important, and you only wanted to enable VLAN tagging (dot1q) for these vlans, so that just the machines assigned to these VLANs could reach each other, and not necessarily an IP of the switch.. then you need to just do this (add the vlans to the VLAN database):


Start by doing this:

show vlan brief

(does it show your vlan 1000 and 10), most new versions of IOS don't create a VLAN in the database when you try to bring up and interface. So you have to create the VLAN, then create the interface.

conf t

vlan 1000
name <description optional>

vlan 10
name <description optional>

That is all you need to properly create the VLANs, however then if you are going to trunk the 2950 to the extreme then you need to setup a trunk port too, to allow both vlans across. Versus an access port that will only allow 1 VLAN.

Any other questions I would be happy to help
 

ScottMac

Moderator<br>Networking<br>Elite member
Mar 19, 2001
5,471
2
0
ON the 2950 (an L2 switch), only one VLAN will show "UP" at a tie: the "administrative" or "natilve" VLAN.

The others are working, but you can only have one active IP address associsted with the switch (the Admin / Native).

Good Luck

Scott
 

Agamar

Golden Member
Oct 9, 1999
1,334
0
0
I have all of our switches (2950 and 3550) configured with 2 vlans. I use the "switchport access" command to put the ports into the vlan. Example:

!
interface FastEthernet0/19
switchport access vlan 180
no ip address
!
interface FastEthernet0/20
switchport access vlan 176
no ip address
!
interface Vlan176
no ip address
no ip route-cache
!
interface Vlan180
ip address 138.xxx.xxx.xxx 255.255.252.0
no ip route-cache
!
ip default-gateway 138.xxx.xxx.254
ip http server
 
Jun 6, 2005
34
0
0
Originally posted by: Agamar
I have all of our switches (2950 and 3550) configured with 2 vlans. I use the "switchport access" command to put the ports into the vlan. Example:

!
interface Vlan176
no ip address
no ip route-cache
!
interface Vlan180
ip address 138.xxx.xxx.xxx 255.255.252.0
no ip route-cache
!




The point being that you only have IP's (L3 interface) assigned to one interface. And, a 3550 is capable of being a multilayer switch (router) while the 2950 isn't.
 

Cooky

Golden Member
Apr 2, 2002
1,408
0
76
Correct me if I'm wrong, but I think OP just wants to connect the cat2950 w/ the Summit 48 switch so that vlans on one switch can communicate w/ the other.

I think what he needs to do is
1.set up VTP correctly so that VLAN information is shared among the switches. Right now the cat2950 is in Transparent mode.
2.creat a dot1q trunk w/ the other switch.
 
Jun 6, 2005
34
0
0
Cooky, that is almost what my first post says. Minus the fact that VTP is a Cisco proprietary protocol and can't share info with an Extreme switch.

1) I don't think it was intended to setup VLAN interfaces.. Just simple create the vlans.

conf t
vlan 1000
vlan 10
end

2) then setup a trunk to pass both vlans


 

spidey07

No Lifer
Aug 4, 2000
65,469
5
76
all you need to do is setup the VLANs with...

vlan 10
vlan 1000

Since your switch is in VTP transparent mode (as it should be) you now have two vlans created. Then as you've done use the "switchport mode access vlan xxx" to assign the ports to that vlan.

Then create the trunk port with..
ing f0/12 <----or whatever port your trunking with
switchport mode trunk
switchport trunk native vlan xxx
^^^^^the xxx is your native vlan and has to match on both sides of the trunk...this is the untagged traffic/vlan.

verify with....
show int f0/12 trunk
^^^^or whatever port is the trunk.


When you use the command "int vlan 10" you are creating a Switched Virtual Interface or SVI. This is a virtual interface used for routing between vlans on a layer 3 switch. On a layer2 switch there is really only one true SVI and that is the management VLAN which is used by the switch itself to communicate (telnet, webserver, snmp, logging, etc)

serch cisco.com for more. I'm sure there is a manual for the switch.
 

Cooky

Golden Member
Apr 2, 2002
1,408
0
76
netman - you did cover it already. I just didn't read it through. My bad.
 
sale-70-410-exam    | Exam-200-125-pdf    | we-sale-70-410-exam    | hot-sale-70-410-exam    | Latest-exam-700-603-Dumps    | Dumps-98-363-exams-date    | Certs-200-125-date    | Dumps-300-075-exams-date    | hot-sale-book-C8010-726-book    | Hot-Sale-200-310-Exam    | Exam-Description-200-310-dumps?    | hot-sale-book-200-125-book    | Latest-Updated-300-209-Exam    | Dumps-210-260-exams-date    | Download-200-125-Exam-PDF    | Exam-Description-300-101-dumps    | Certs-300-101-date    | Hot-Sale-300-075-Exam    | Latest-exam-200-125-Dumps    | Exam-Description-200-125-dumps    | Latest-Updated-300-075-Exam    | hot-sale-book-210-260-book    | Dumps-200-901-exams-date    | Certs-200-901-date    | Latest-exam-1Z0-062-Dumps    | Hot-Sale-1Z0-062-Exam    | Certs-CSSLP-date    | 100%-Pass-70-383-Exams    | Latest-JN0-360-real-exam-questions    | 100%-Pass-4A0-100-Real-Exam-Questions    | Dumps-300-135-exams-date    | Passed-200-105-Tech-Exams    | Latest-Updated-200-310-Exam    | Download-300-070-Exam-PDF    | Hot-Sale-JN0-360-Exam    | 100%-Pass-JN0-360-Exams    | 100%-Pass-JN0-360-Real-Exam-Questions    | Dumps-JN0-360-exams-date    | Exam-Description-1Z0-876-dumps    | Latest-exam-1Z0-876-Dumps    | Dumps-HPE0-Y53-exams-date    | 2017-Latest-HPE0-Y53-Exam    | 100%-Pass-HPE0-Y53-Real-Exam-Questions    | Pass-4A0-100-Exam    | Latest-4A0-100-Questions    | Dumps-98-365-exams-date    | 2017-Latest-98-365-Exam    | 100%-Pass-VCS-254-Exams    | 2017-Latest-VCS-273-Exam    | Dumps-200-355-exams-date    | 2017-Latest-300-320-Exam    | Pass-300-101-Exam    | 100%-Pass-300-115-Exams    |
http://www.portvapes.co.uk/    | http://www.portvapes.co.uk/    |